summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-19 13:28:16 -0500
committerLeo Famulari <leo@famulari.name>2016-11-19 23:43:32 -0500
commit764c5662211793d381b6c4a85f6a1ef4ad353c3f (patch)
tree693b326ff7341940a8bf3409a0840cb918a84355 /gnu/packages/gnupg.scm
parent9fff9e6484a1ebe5246e2811c5d74fbdab43313c (diff)
downloadpatches-764c5662211793d381b6c4a85f6a1ef4ad353c3f.tar
patches-764c5662211793d381b6c4a85f6a1ef4ad353c3f.tar.gz
gnu: gnupg: Update to 2.1.16.
* gnu/packages/gnupg.scm (gnupg): Update to 2.1.16. [arguments]: Remove obsolete substitution from 'patch-paths' phase. Remove 'set-home' phase. Add 'set-gnupg-home' phase.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index fccaa9708f..0a6eba236c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -213,14 +213,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.1.15")
+ (version "2.1.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1pgz02gd84ab94w4xdg67p9z8kvkyr9d523bvcxxd2hviwh1m362"))))
+ "0i483m9q032a0s50f1izb213g4h5i7pcgn395m6hvl3sg2kadfa9"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -245,8 +245,6 @@ compatible to GNU Pth.")
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "tests/openpgp/defs.inc"
- (("/bin/pwd") (which "pwd")))
(substitute* "scd/scdaemon.c"
(("\"(libpcsclite\\.so[^\"]*)\"" _ name)
(string-append "\"" (assoc-ref inputs "pcsc-lite")
@@ -256,13 +254,12 @@ compatible to GNU Pth.")
(lambda _
(substitute* (find-files "tests" ".\\.scm$")
(("/usr/bin/env gpgscm")
- (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
- (add-before 'check 'set-home
- ;; Some tests require write access to $HOME, otherwise leading to
- ;; 'failed to create directory /homeless-shelter/.asy' error.
- ;; TODO Try removing this phase for GnuPG 2.1.16.
+ (string-append (getcwd) "/tests/gpgscm/gpgscm")))
+ #t))
+ ;; If this variable is undefined, /bin/pwd is invoked.
+ (add-before 'check 'set-gnupg-home
(lambda _
- (setenv "HOME" "/tmp")
+ (setenv "GNUPGHOME" (getcwd))
#t)))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")