summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-06 14:02:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-06 14:03:38 +0200
commit6b982a7846780c90e67ed872b30e1f4d6aa819dc (patch)
tree2adc95ed7e3c30c322999eb37c812d11b5240a27 /gnu/packages/gnupg.scm
parent4604a98855c74134fe3f6ee1ec8205deff1b1ded (diff)
downloadpatches-6b982a7846780c90e67ed872b30e1f4d6aa819dc.tar
patches-6b982a7846780c90e67ed872b30e1f4d6aa819dc.tar.gz
gnu: Add qgpgme.
* gnu/packages/gnupg.scm (qgpgme): New variable.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c2b02789bf..9efd32a3f8 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -407,6 +407,35 @@ instead. This way bug fixes or improvements can be done at a central place
and every application benefits from this.")
(license license:lgpl2.1+)))
+(define-public qgpgme
+ (package
+ (inherit gpgme)
+ (name "qgpgme")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'chdir-and-symlink
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gpgme (assoc-ref inputs "gpgme")))
+ (symlink (string-append gpgme "/lib/libgpgmepp.la")
+ "lang/cpp/src/libgpgmepp.la")
+ (symlink (string-append gpgme "/lib/libgpgme.la")
+ "src/libgpgme.la"))
+ (chdir "lang/qt")
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gpgme" ,gpgme)
+ ("qtbase" ,qtbase)
+ ,@(package-inputs gpgme)))
+ (synopsis "Qt API bindings for gpgme")
+ (description "QGpgme provides a very high level Qt API around GpgMEpp.
+
+QGpgME was originally developed as part of libkleo and incorporated into
+gpgpme starting with version 1.7.")
+ (license license:gpl2+))) ;; Note: this differs from gpgme
+
(define-public python-gpg
(package
(name "python-gpg")