summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-27 20:21:26 -0400
committerMark H Weaver <mhw@netris.org>2016-10-27 20:21:26 -0400
commit3d82676919b952d0a7e205fa5da6320b1cf21e21 (patch)
tree02586fee407b667fc9e082f98ad70356eedd7864 /gnu/packages/gnupg.scm
parentf9a65318ddc34a84fea128b756d23ad619f519dc (diff)
parent7500e42b3e51fa9ba5fb2ba552f168081b7f044a (diff)
downloadpatches-3d82676919b952d0a7e205fa5da6320b1cf21e21.tar
patches-3d82676919b952d0a7e205fa5da6320b1cf21e21.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index dd75ea5c34..a3a42cc2f2 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Nils Gillmann <ng0@libertad.pw>
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages security-token)
#:use-module (gnu packages tls)
#:use-module (guix packages)
#:use-module (guix download)
@@ -233,6 +235,7 @@ compatible to GNU Pth.")
("libksba" ,libksba)
("npth" ,npth)
("openldap" ,openldap)
+ ("pcsc-lite" ,pcsc-lite)
("readline" ,readline)
("sqlite" ,sqlite)
("zlib" ,zlib)))
@@ -240,10 +243,14 @@ compatible to GNU Pth.")
`(#:configure-flags '("--enable-gpg2-is-gpg")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'patch-config-files
- (lambda _
+ (add-before 'configure 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "tests/openpgp/defs.inc"
(("/bin/pwd") (which "pwd")))
+ (substitute* "scd/scdaemon.c"
+ (("\"(libpcsclite\\.so[^\"]*)\"" _ name)
+ (string-append "\"" (assoc-ref inputs "pcsc-lite")
+ "/lib/" name "\"")))
#t))
(add-after 'build 'patch-scheme-tests
(lambda _