summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-20 16:47:18 -0500
committerLeo Famulari <leo@famulari.name>2017-12-21 12:37:25 -0500
commit806e891e85aff27ea87c4e60930d8c4ed7d5091f (patch)
tree4d10ecdbe9ba787e58a9849e210e670819ac9f88 /gnu/packages/gnupg.scm
parent0c9c9526bb3fb665997b3b054f8b57ffdb559043 (diff)
downloadpatches-806e891e85aff27ea87c4e60930d8c4ed7d5091f.tar
patches-806e891e85aff27ea87c4e60930d8c4ed7d5091f.tar.gz
gnu: gnupg@2.0: Superseded by the latest GnuPG.
The 2.0 series of GnuPG will stop receiving upstream support on 2017-12-31. From the release announcement of GnuPG 2.2.0: "This release marks the start of a new long term support series to replace the 2.0.x series which will reach end-of-life on 2017-12-31." https://lists.gnupg.org/pipermail/gnupg-announce/2017q3/000413.html * gnu/packages/gnupg.scm (gnupg-2.0)[properties]: New field.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 7a791aecd2..247e907b15 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -341,7 +341,8 @@ libskba (working with X.509 certificates and CMS data).")
;; Keep the old name around to ease transition.
(symlink "gpgv" "gpgv2")
(symlink "gpg" "gpg2")
- #t)))))))))
+ #t)))))))
+ (properties `((superseded . ,gnupg)))))
(define-public gnupg-1
(package (inherit gnupg)