summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-27 18:44:48 -0400
committerLeo Famulari <leo@famulari.name>2020-03-29 15:25:50 -0400
commite5b44b06b3fb19c897fb3e430bd41941905e101f (patch)
tree8bf2ba3e4644b9b2455a6ce6ab7c10c612ef3ecd /gnu/packages/gnupg.scm
parent8f83699ba00743d258b497e0e5285989996ee559 (diff)
downloadpatches-e5b44b06b3fb19c897fb3e430bd41941905e101f.tar
patches-e5b44b06b3fb19c897fb3e430bd41941905e101f.tar.gz
gnu: GnuPG: Really use ~/.guix-profile/bin/pinentry by default.base-for-series-3322
Fixes <https://bugs.gnu.org/24076>. * gnu/packages/patches/gnupg-default-pinentry.patch: New file. Use $HOME to find the user's Guix profile and installed pinentry. * gnu/local.mk (dist_patch_DATA): Add the patch. * gnu/packages/gnupg.scm (gnupg)[source]: Use it.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 856c01a6d8..04bb705712 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -252,6 +252,7 @@ compatible to GNU Pth.")
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
+ (patches (search-patches "gnupg-default-pinentry.patch"))
(sha256
(base32
"0c6a4v9p6qzhsw1pfcwc459bxpc8hma0w9z8iqb9khvligack9q4"))))