summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-18 09:19:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-18 11:18:39 +0100
commit9c2d0a0369f75bd01ed9834b45432014b441ca15 (patch)
tree6f392c4e6596b8cf7d473936862bb399d400c08e /gnu/packages/gnupg.scm
parent90dbd984f89590f189c2b2015ed0be3b29014ca2 (diff)
downloadpatches-9c2d0a0369f75bd01ed9834b45432014b441ca15.tar
patches-9c2d0a0369f75bd01ed9834b45432014b441ca15.tar.gz
gnu: Remove duplicate from (gnu packages gnupg).
* gnu/packages/gnupg.scm (perl-gnupg-interface): Remove duplicate.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm87
1 files changed, 25 insertions, 62 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 15fd7855eb..7ac14981c1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -548,37 +548,37 @@ and signature functionality from Python programs.")
(package
(name "perl-gnupg-interface")
(version "0.52")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://cpan/authors/id/A/AL/ALEXMV/GnuPG-Interface-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "0dgx8yhdsmhkazcrz14n4flrk1afv7azgl003hl4arxvi1d9yyi4"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AL/ALEXMV/"
+ "GnuPG-Interface-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dgx8yhdsmhkazcrz14n4flrk1afv7azgl003hl4arxvi1d9yyi4"))))
(build-system perl-build-system)
(arguments
- '(;; Result: FAIL
- ;; Failed 10/20 test programs. 21/52 subtests failed.
- #:tests? #f))
- (native-inputs
- `(("perl-module-install" ,perl-module-install)
- ("which" ,which)))
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; FIXME: This test fails for unknown reasons
+ (add-after 'unpack 'delete-broken-test
+ (lambda _
+ (delete-file "t/encrypt_symmetrically.t")
+ #t)))))
(inputs
- `(("gnupg" ,gnupg)))
+ `(("gnupg" ,gnupg-1)))
(propagated-inputs
`(("perl-moo" ,perl-moo)
- ("perl-moox-late" ,perl-moox-late)
- ("perl-moox-handlesvia" ,perl-moox-handlesvia)))
- (home-page "http://search.cpan.org/~alexmv/GnuPG-Interface/")
+ ("perl-moox-handlesvia" ,perl-moox-handlesvia)
+ ("perl-moox-late" ,perl-moox-late)))
+ (native-inputs
+ `(("which" ,which)
+ ("perl-module-install" ,perl-module-install)))
+ (home-page "http://search.cpan.org/dist/GnuPG-Interface/")
(synopsis "Perl interface to GnuPG")
- (description
- "@code{GnuPG::Interface} and its associated modules are designed to
-provide an object-oriented method for interacting with GnuPG, being able to
-perform functions such as but not limited to encrypting, signing, decryption,
-verification, and key-listing parsing.")
+ (description "@code{GnuPG::Interface} and its associated modules are
+designed to provide an object-oriented method for interacting with GnuPG,
+being able to perform functions such as but not limited to encrypting,
+signing, decryption, verification, and key-listing parsing.")
(license license:perl-license)))
(define-public pius
@@ -856,43 +856,6 @@ them to transform your existing public key into a secret key.")
files, to verify signatures, and to manage the private and public keys.")
(license license:gpl3+)))
-(define-public perl-gnupg-interface
- (package
- (name "perl-gnupg-interface")
- (version "0.52")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AL/ALEXMV/"
- "GnuPG-Interface-" version ".tar.gz"))
- (sha256
- (base32
- "0dgx8yhdsmhkazcrz14n4flrk1afv7azgl003hl4arxvi1d9yyi4"))))
- (build-system perl-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; FIXME: This test fails for unknown reasons
- (add-after 'unpack 'delete-broken-test
- (lambda _
- (delete-file "t/encrypt_symmetrically.t")
- #t)))))
- (inputs
- `(("gnupg" ,gnupg-1)))
- (propagated-inputs
- `(("perl-moo" ,perl-moo)
- ("perl-moox-handlesvia" ,perl-moox-handlesvia)
- ("perl-moox-late" ,perl-moox-late)))
- (native-inputs
- `(("which" ,which)
- ("perl-module-install" ,perl-module-install)))
- (home-page "http://search.cpan.org/dist/GnuPG-Interface/")
- (synopsis "Perl interface to GnuPG")
- (description "@code{GnuPG::Interface} and its associated modules are
-designed to provide an object-oriented method for interacting with GnuPG,
-being able to perform functions such as but not limited to encrypting,
-signing, decryption, verification, and key-listing parsing.")
- (license license:perl-license)))
-
(define-public parcimonie
(package
(name "parcimonie")