summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-24 15:52:05 +0000
committerLudovic Courtès <ludo@gnu.org>2017-09-26 10:37:18 +0200
commit8384499c04978dc8e16f2beb9ee940293c7800c5 (patch)
tree36ee9c5c4354b086158dd6f921e48ed88b0fdd98 /gnu/packages/gnupg.scm
parentb36524c1b82f6807a9abdd05b0f767397344b682 (diff)
downloadpatches-8384499c04978dc8e16f2beb9ee940293c7800c5.tar
patches-8384499c04978dc8e16f2beb9ee940293c7800c5.tar.gz
gnu: Add gpa.
* gnu/packages/gnupg.scm (gpa): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c6af5caa49..ffad57ef5e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
@@ -822,3 +822,31 @@ qualities. To reconstruct a secret key, you re-enter those
bytes (whether by hand, OCR, QR code, or the like) and paperkey can use
them to transform your existing public key into a secret key.")
(license license:gpl2+)))
+
+(define-public gpa
+ (package
+ (name "gpa")
+ (version "0.9.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnupg/gpa/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "09xphbi2456qynwqq5n0yh0zdmdi2ggrj3wk4hsyh5lrzlvcrff3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnupg" ,gnupg)
+ ("gpgme" ,gpgme)
+ ("libassuan" ,libassuan)
+ ("libgpg-error" ,libgpg-error)
+ ("gtk+-2" ,gtk+-2)))
+ (home-page "https://gnupg.org/software/gpa/")
+ (synopsis "Graphical user interface for GnuPG")
+ (description
+ "GPA, the GNU Privacy Assistant, is a graphical user interface for
+@uref{https://gnupg.org, GnuPG}. It can be used to encrypt, decrypt, and sign
+files, to verify signatures, and to manage the private and public keys.")
+ (license license:gpl3+)))