summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-25 00:18:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-25 00:18:15 +0300
commit45477c6a7d057e26046c9ca90b7bf7869ea71803 (patch)
treef7db626eeaca359ed0a333c52368803b0ab7a9ff /gnu/packages/gnupg.scm
parent35d28c60133a5b07766df9c7b1e91930b2bff24d (diff)
downloadpatches-45477c6a7d057e26046c9ca90b7bf7869ea71803.tar
patches-45477c6a7d057e26046c9ca90b7bf7869ea71803.tar.gz
gnu: gnupg@2.1: Use 'modify-phases'.
* gnu/packages/gnupg.scm (gnupg@2.1)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 9a6694e6c2..d18a8de22c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -236,12 +236,12 @@ compatible to GNU Pth.")
(arguments
`(#:configure-flags '("--enable-gpg2-is-gpg")
#:phases
- (alist-cons-before
- 'configure 'patch-config-files
- (lambda _
- (substitute* "tests/openpgp/defs.inc"
- (("/bin/pwd") (which "pwd"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-config-files
+ (lambda _
+ (substitute* "tests/openpgp/defs.inc"
+ (("/bin/pwd") (which "pwd")))
+ #t)))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")
(description