summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-11-15 14:44:36 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-16 08:45:15 +0100
commitb95c17c58b83273af398363c371e1c8095ca6db8 (patch)
tree21d75a24573af867f204356150b146eb360d8252 /gnu/packages/gnupg.scm
parentcc6f49121bcf2c5d342045f76c94f452f96e5f78 (diff)
downloadpatches-b95c17c58b83273af398363c371e1c8095ca6db8.tar
patches-b95c17c58b83273af398363c371e1c8095ca6db8.tar.gz
gnu: Move Python packages from crypto to python-crypto.
* gnu/packages/crypto.scm (python-asn1crypto, python2-asn1crypto) (python-pynacl, python2-roca-detect): Move to python-crypto.scm. * gnu/packages/gnupg.scm (python2-pgpdump): Move to python-crypto.scm. * gnu/packages/python-crypto.scm (python-asn1crypto, python2-asn1crypto) (python-pynacl, python2-pgpdump, python2-roca-detect): New variables.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index d179d41963..15fd7855eb 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -979,34 +979,3 @@ keyring content. Parcimonie is a daemon that fetches one key at a time using
the Tor network, waits a bit, changes the Tor circuit being used, and starts
over.")
(license license:gpl1+)))
-
-(define-public python2-pgpdump
- (package
- (name "python2-pgpdump")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pgpdump" version))
- (sha256
- (base32
- "0s4nh8h7qsdj2yf29bspjs1zvxd4lcd11r6g11dp7fppgf2h0iqw"))))
- (build-system python-build-system)
-
- ;; Currently fails to build with Python 3.
- (arguments `(#:python ,python-2))
-
- (home-page "https://github.com/toofishes/python-pgpdump")
- (synopsis "Python library for parsing PGP packets")
- (description
- "Python-pgpdump is an OpenPGP packet parser based on
-@uref{http://www.mew.org/~kazu/proj/pgpdump/, pgpdump}. It notably supports:
-
-@itemize
-@item signature packets;
-@item public key packets;
-@item secret key packets;
-@item trust, user ID, and user attribute packets;
-@item ASCII-armor decoding and CRC check.
-@end itemize\n")
- (license license:bsd-3)))