summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-02-12 16:15:32 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-12 18:36:46 +0100
commit7af52bd58c834f46e54f27592b6193604f7119fb (patch)
treefe3c4addf92af4f195c214374674c3b1e9f3c792 /gnu/packages/gnunet.scm
parentbdff90a16a99ad95bd76a14847e1507454990588 (diff)
downloadpatches-7af52bd58c834f46e54f27592b6193604f7119fb.tar
patches-7af52bd58c834f46e54f27592b6193604f7119fb.tar.gz
gnu: gnunet: Fix failing testcases.
* gnu/packages/gnunet.scm (gnurl): Add pkg-config. * gnu/packages/patches/gnunet-fix-tests.patch: Append fix for integration testcases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index f3448a7e63..960a5d725c 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -153,8 +153,9 @@ and support for SSL3 and TLS.")
("libidn" ,libidn)
("zlib" ,zlib)))
(native-inputs
- `(("perl" ,perl)
- ("groff" ,groff)
+ `(("groff" ,groff)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
("python" ,python-2)))
(arguments
`(#:configure-flags '("--enable-ipv6" "--with-gnutls" "--without-libssh2"
@@ -211,7 +212,8 @@ supports HTTPS, HTTPS and GnuTLS.")
(search-patch "gnunet-fix-scheduler.patch")
;; Patch to fix bugs in testcases:
;; * Disable peerinfo-tool tests as they depend on reverse DNS lookups
- ;; * Allow revocation testcase to run on loopback; upstream: #32130
+ ;; * Allow revocation and integration-tests testcases to run on
+ ;; loopback; upstream: #32130, #32326
;; * Skip GNS testcases requiring DNS lookups; upstream: #32118
(search-patch "gnunet-fix-tests.patch")))
(patch-flags '("-p0"))))