summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-08-08 16:24:41 -0400
committerLeo Famulari <leo@famulari.name>2018-08-08 16:35:18 -0400
commite19f9c24aa74d76428a4a4cf97aef0f626fd9466 (patch)
treecbbc139098e6f9d526f3e2cf3d5bbef9df25189d /gnu/packages/gnome.scm
parent62694caa440579d48e5bb4ba13016c0d4a88051f (diff)
downloadpatches-e19f9c24aa74d76428a4a4cf97aef0f626fd9466.tar
patches-e19f9c24aa74d76428a4a4cf97aef0f626fd9466.tar.gz
gnu: epiphany: Correctly set the library RUNPATH.
* gnu/packages/gnome.scm (epiphany): Set the runpath in #:configure-flags.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 586cfc9686..6fcd3ceb9c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -4190,7 +4190,11 @@ a secret password store, an adblocker, and a modern UI.")
;; subsystem
;; FAIL
'(#:tests? #f
- #:glib-or-gtk? #t))
+ #:glib-or-gtk? #t
+ #:configure-flags
+ ;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
+ (list (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/epiphany"))))
(propagated-inputs
`(("dconf" ,dconf)))
(native-inputs