summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-26 01:11:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 01:11:32 +0200
commit6a0427af6cc3d52c0efc09262e90c1858ae6f40e (patch)
treeafedf3a5728dfac46c20aed448326debccf96562 /gnu/packages/gnome.scm
parent985d542e028517b2888fa61831233a2b60dc7d48 (diff)
parent3b97a1779f3b65d582b8edc8c154b6414314b946 (diff)
downloadpatches-6a0427af6cc3d52c0efc09262e90c1858ae6f40e.tar
patches-6a0427af6cc3d52c0efc09262e90c1858ae6f40e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm60
1 files changed, 25 insertions, 35 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 98ead71e34..86989f9dc9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -115,6 +115,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages rdesktop)
#:use-module (gnu packages scanner)
#:use-module (gnu packages selinux)
@@ -4094,35 +4096,27 @@ work and the interface is well tested.")
(define-public eolie
(package
(name "eolie")
- (version "0.9.15")
+ (version "0.9.37")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/gnumdk/eolie/"
- "releases/download/" version
- "/eolie-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.gnome.org/World/eolie/"
+ "uploads/4341cb428b7a45670308ee3fb3fa07dd/"
+ "eolie-" version ".tar.xz"))
(sha256
(base32
- "0glydxp1xh85gfidk1l9miqn6qxdbvvk5s3iy0pjlv8nrs3263jd"))))
- (build-system glib-or-gtk-build-system)
+ "126m0nwwy3lqv7z8aj9hiwangih03b1nlkg3xja9p7wbf7zcvp2n"))))
+ (build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:glib-or-gtk? #t
+ #:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "meson" "build"
- "--prefix" (assoc-ref outputs "out")))))
- (replace 'check
- (lambda _ (zero? (system* "ninja" "-C" "build" "test"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "ninja" "-C" "build" "install"))))
(add-after 'wrap 'wrap-more
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
;; These libraries must be on LD_LIBRARY_PATH.
(libs '("gtkspell3" "webkitgtk" "libsoup" "libsecret"
"atk" "gtk+" "gsettings-desktop-schemas"
+ "gcc:lib" ; needed b/c webkitgtk is built with gcc-7
"gobject-introspection"))
(path (string-join
(map (lambda (lib)
@@ -4135,12 +4129,12 @@ work and the interface is well tested.")
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))
#t)))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("gcc:lib" ,gcc-7 "lib") ; needed because webkitgtk is built with gcc-7
+ ("intltool" ,intltool)
("itstool" ,itstool)
("pkg-config" ,pkg-config)
- ("meson" ,meson-for-build)
- ("ninja" ,ninja)
("python" ,python)
+ ("glib:bin" ,glib "bin")
("gtk+" ,gtk+ "bin")))
(inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -4150,12 +4144,14 @@ work and the interface is well tested.")
("atk" ,atk) ; propagated by gtk+, but we need it in LD_LIBRARY_PATH
("python" ,python-wrapper)
("python-dateutil" ,python-dateutil)
+ ("python-pyfxa" ,python-pyfxa)
("python-pygobject" ,python-pygobject)
("python-pycairo" ,python-pycairo)
+ ("python-pycrypto" ,python-pycrypto)
("libsecret" ,libsecret)
("gtkspell3" ,gtkspell3)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("webkitgtk" ,webkitgtk)))
+ ("webkitgtk" ,webkitgtk-2.22)))
(home-page "https://wiki.gnome.org/Apps/Eolie")
(synopsis "Web browser for GNOME")
(description
@@ -4193,6 +4189,7 @@ a secret password store, an adblocker, and a modern UI.")
`(("dconf" ,dconf)))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gcc" ,gcc-7) ; needed because webkitgtk-2.22 is compiled with gcc-7
("glib:bin" ,glib "bin") ; for glib-mkenums
("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
@@ -4213,7 +4210,7 @@ a secret password store, an adblocker, and a modern UI.")
("libxslt" ,libxslt)
("nettle" ,nettle) ; for hogweed
("sqlite" ,sqlite)
- ("webkitgtk" ,webkitgtk)))
+ ("webkitgtk" ,webkitgtk-2.22)))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description
@@ -6936,7 +6933,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
(define-public gspell
(package
(name "gspell")
- (version "1.4.2")
+ (version "1.8.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6944,7 +6941,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
name "-" version ".tar.xz"))
(sha256
(base32
- "1683vyyfq3q0ph665jj6id8hnlyid4qxzmqiwpv97gmz8zksg6x5"))
+ "1rdv873ixhwr15jwgc2z6k6y0hj353fqnwsy7zkh0c30qwiiv6l1"))
(patches (search-patches "gspell-dash-test.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -6978,7 +6975,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
("aspell-dict-en" ,aspell-dict-en)
("xorg-server" ,xorg-server)))
(propagated-inputs
- `(("enchant" ,enchant))) ; enchant.pc is required by gspell-1.pc
+ `(("enchant" ,enchant))) ;enchant.pc is required by gspell-1.pc
(home-page "https://wiki.gnome.org/Projects/gspell")
(synopsis "GNOME's alternative spell checker")
(description
@@ -7230,7 +7227,7 @@ mp3, Ogg Vorbis and FLAC")
(license license:gpl2+)))
(define-public workrave
- (let ((commit "v1_10_20"))
+ (let ((commit "v1_10_21"))
(package
(name "workrave")
(version (string-map (match-lambda
@@ -7242,18 +7239,11 @@ mp3, Ogg Vorbis and FLAC")
(uri (git-reference
(url "https://github.com/rcaelers/workrave.git")
(commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "099a87zkrkmsgfz9isrfm89dh545x52891jh6qxmn19h6wwsi941"))))
+ "150qca8c552fakjlzkgarsxgp87l1xcwn19svqsa9d0cygqxjgia"))))
(build-system glib-or-gtk-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (invoke "sh" "autogen.sh")
- #t)))))
(propagated-inputs `(("glib" ,glib)
("gtk+" ,gtk+)
("gdk-pixbuf" ,gdk-pixbuf)