summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-02 19:44:55 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-02 19:44:55 +0200
commit22e32e6938431c814e35dd830a65e7035d9dc471 (patch)
treed00d56eae6f2bc96c3b63e8c4a15dad60de1e66e /gnu/packages/gnome.scm
parent1369442be92fa6411755a01adc5f3abfdc47b49d (diff)
downloadpatches-22e32e6938431c814e35dd830a65e7035d9dc471.tar
patches-22e32e6938431c814e35dd830a65e7035d9dc471.tar.gz
gnu: gnome: Add gsettings-desktop-schemas.
* gnu/packages/gnome.scm (gsettings-desktop-schemas): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 279bbe3ec7..4ac88ec342 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -58,6 +58,32 @@ Gnome project. It includes xml2po tool which makes it easier to translate
and keep up to date translations of documentation.")
(license gpl2+))) ; xslt under lgpl
+(define-public gsettings-desktop-schemas
+ (package
+ (name "gsettings-desktop-schemas")
+ (version "3.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (string-copy version 0 (string-rindex version #\.)) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1km8qxwrzvravmg8j680qv64bwnwbdgrmy8bqmhs0dgxn2b1as6a"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://launchpad.net/gsettings-desktop-schemas")
+ (synopsis
+ "GNOME settings for various desktop components")
+ (description
+ "Gsettings-desktop-schemas contains a collection of GSettings schemas
+for settings shared by various components of the GNOME desktop.")
+ (license lgpl2.1+)))
+
(define-public libnotify
(package
(name "libnotify")