summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-07 00:50:25 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-07 00:50:25 +0200
commit6af7c2b178b4d9bf16aced8bbfc1518643425f13 (patch)
treec71a79116d94659576096362907160d5b82b367d /gnu/packages/gnome.scm
parent869250809bddcf8eab26ecdedabad6fc060751dd (diff)
parente921234d02c926b5a95498aed1280b6346dd0878 (diff)
downloadpatches-6af7c2b178b4d9bf16aced8bbfc1518643425f13.tar
patches-6af7c2b178b4d9bf16aced8bbfc1518643425f13.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 46eae3608a..586cfc9686 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2928,14 +2928,15 @@ faster results and to avoid unnecessary server load.")
(define-public upower
(package
(name "upower")
- (version "0.99.4")
+ (version "0.99.8")
(source (origin
(method url-fetch)
- (uri (string-append "https://upower.freedesktop.org/releases/"
- name "-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.freedesktop.org/upower/upower/"
+ "uploads/9125ab7ee96fdc4ecc68cfefb50c1cab/"
+ "upower-" version ".tar.xz"))
(sha256
(base32
- "1c1ph1j1fnrf3vipxb7ncmdfc36dpvcvpsv8n8lmal7grjk2b8ww"))
+ "00lzr0vyxz5lvmgya48gdb2cdgmfdim4b34jlfdyqakk1i9sl8xv"))
(patches (search-patches "upower-builddir.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -2946,17 +2947,7 @@ faster results and to avoid unnecessary server load.")
#:configure-flags (list "--localstatedir=/var"
(string-append "--with-udevrulesdir="
(assoc-ref %outputs "out")
- "/lib/udev/rules.d"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/true
- (lambda _
- (substitute* "configure"
- (("/bin/true") (which "true")))))
- (add-before 'configure 'patch-integration-test
- (lambda _
- (substitute* "src/linux/integration-test"
- (("/usr/bin/python3") (which "python3"))))))))
+ "/lib/udev/rules.d"))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
@@ -2971,6 +2962,9 @@ faster results and to avoid unnecessary server load.")
`(("dbus-glib" ,dbus-glib)
("libgudev" ,libgudev)
("libusb" ,libusb)))
+ (propagated-inputs
+ ;; In Requires of upower-glib.pc.
+ `(("glib" ,glib)))
(home-page "https://upower.freedesktop.org/")
(synopsis "System daemon for managing power devices")
(description