summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2019-09-06 06:35:34 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-16 12:17:48 +0200
commitad6e168b3f29576d92b00725dedbb38cd5f05e46 (patch)
tree4cebf15eece036b0111af6fcf34e79a65fa06ad7 /gnu/packages/gnome.scm
parenteb2e9ef4d964177cdd161ec30e9ea3c900bec8aa (diff)
downloadpatches-ad6e168b3f29576d92b00725dedbb38cd5f05e46.tar
patches-ad6e168b3f29576d92b00725dedbb38cd5f05e46.tar.gz
gnu: evolution: Wrap with required path variables.
Fixes <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36896>. * gnu/packages/gnome.scm (evolution)[arguments]: Add a ‘wrap-program’ phase. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5dc18b3bb5..f2edf92bd1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8122,11 +8123,21 @@ generic enough to work for everyone.")
(build-system cmake-build-system)
(arguments
`(#:configure-flags
- (list "-DENABLE_PST_IMPORT=OFF" ; libpst is not packaged
- "-DENABLE_LIBCRYPTUI=OFF"))) ; libcryptui hasn't seen a release
- ; in four years and cannot be built.
+ (list "-DENABLE_PST_IMPORT=OFF" ; libpst is not packaged
+ "-DENABLE_LIBCRYPTUI=OFF") ; libcryptui hasn't seen a release
+ ; in four years and cannot be built
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/evolution")
+ `("XDG_DATA_DIRS" ":" prefix (,(getenv "XDG_DATA_DIRS")))
+ `("GSETTINGS_SCHEMA_DIR" =
+ (,(string-append out "/share/glib-2.0/schemas")))))
+ #t)))))
(native-inputs
- `(("glib" ,glib "bin") ; glib-mkenums
+ `(("glib" ,glib "bin") ; glib-mkenums
("pkg-config" ,pkg-config)
("intltool" ,intltool)
("itstool" ,itstool)))
@@ -8134,6 +8145,7 @@ generic enough to work for everyone.")
`(("enchant" ,enchant)
("evolution-data-server" ,evolution-data-server) ; must be the same version
("gcr" ,gcr)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gnome-autoar" ,gnome-autoar)
("gnome-desktop" ,gnome-desktop)
("gtkspell3" ,gtkspell3)