summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-12-05 22:32:10 +0100
committerKei Kebreau <kkebreau@posteo.net>2019-06-20 23:24:38 -0400
commitd0b19e445cd542b8336e47801c6aacd9361ed5a7 (patch)
tree8da207598380854dd9b44ace321144b4457c82ee /gnu/packages/gnome.scm
parent817b3fd1d57f51db04b608769beffa1b4d7cf72b (diff)
downloadpatches-d0b19e445cd542b8336e47801c6aacd9361ed5a7.tar
patches-d0b19e445cd542b8336e47801c6aacd9361ed5a7.tar.gz
gnu: libgdata: Update to 0.17.9.
* gnu/packages/gnome.scm (libgdata): Update to 0.17.9. [inputs]: Move glib, json-glib, and libsoup from here... [propagated-inputs]: ...to here. * gnu/packages/patches/libgdata-fix-tests.patch: Remove file. * gnu/packages/patches/libgdata-glib-duplicate-tests.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Remove patches.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bc59c58d4f..221c79e6a9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -357,10 +357,12 @@ relationship modeling, and network diagrams. The program supports various file
formats like PNG, SVG, PDF and EPS.")
(license license:gpl2+))))
+;; This is the unstable release, but it is required for the current stable
+;; release of gvfs (1.38.1).
(define-public libgdata
(package
(name "libgdata")
- (version "0.16.1")
+ (version "0.17.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -368,10 +370,7 @@ formats like PNG, SVG, PDF and EPS.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09q8h1129xjpw33rvzz7856drygxwlm0s64z9cm0vbmjxiqy0h47"))
- (patches
- (search-patches "libgdata-fix-tests.patch"
- "libgdata-glib-duplicate-tests.patch"))))
+ "0fj54yqxdapdppisqm1xcyrpgcichdmipq0a0spzz6009ikzgi45"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -391,14 +390,14 @@ formats like PNG, SVG, PDF and EPS.")
("uhttpmock" ,uhttpmock)))
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
- ("glib" ,glib)
- ("glib-networking" ,glib-networking)
- ("json-glib" ,json-glib)
- ("libsoup" ,libsoup)))
+ ("glib-networking" ,glib-networking)))
(propagated-inputs
`(("gcr" ,gcr)
+ ("glib" ,glib)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("json-glib" ,json-glib)
("liboauth" ,liboauth)
+ ("libsoup" ,libsoup)
("libxml2" ,libxml2)))
(home-page "https://wiki.gnome.org/Projects/libgdata")
(synopsis "Library for accessing online service APIs")