summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-29 10:37:53 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-02 22:06:45 +0800
commitafc25242a1a195fe197c626b8e4860e17a42cabd (patch)
treee1f45fce78f462feb74ccaa7351c1e02db43403d /gnu/packages/gnome.scm
parent2ed6522ac3e188729ea7ce833f126f438697b4a5 (diff)
downloadpatches-afc25242a1a195fe197c626b8e4860e17a42cabd.tar
patches-afc25242a1a195fe197c626b8e4860e17a42cabd.tar.gz
gnu: gedit: Enable Python Console plugin.
* gnu/packages/gnome.scm (gedit)[arguments]: Wrap with PYTHONPATH.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 24708e3f21..f54fd29305 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3944,9 +3944,12 @@ javascript engine and the GObject introspection framework.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gtksourceview (assoc-ref inputs "gtksourceview"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (python-path (getenv "PYTHONPATH")))
(wrap-program (string-append out "/bin/gedit")
+ ;; For plugins.
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("PYTHONPATH" ":" prefix (,python-path))
;; For language-specs.
`("XDG_DATA_DIRS" ":" prefix (,(string-append gtksourceview
"/share")))))