summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-02-13 14:22:17 -0500
committerLudovic Courtès <ludo@gnu.org>2019-02-17 00:04:57 +0100
commitdef6d6b61685f69421df80cb524ba94da5dadd42 (patch)
treecd32bffaed44080dd938fac1aafc05b49e475dd0 /gnu/packages/gnome.scm
parent69544798ea9cc3b6d06c4b40e3560fd7a17215b2 (diff)
downloadpatches-def6d6b61685f69421df80cb524ba94da5dadd42.tar
patches-def6d6b61685f69421df80cb524ba94da5dadd42.tar.gz
gnu: gdm: Use absolute path for gnome-session.
* gnu/packages/gnome.scm (gdm)[arguments]: Modify the pre-configure phase to substitute in the absolute path of gnome-session. [inputs]: Add gnome-session. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ec6d3fb8c6..386203356c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5431,7 +5431,7 @@ libxml2.")
(modify-phases %standard-phases
(add-before
'configure 'pre-configure
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
;; We don't have <systemd/sd-daemon.h>.
(substitute* '("common/gdm-log.c"
"daemon/gdm-server.c"
@@ -5492,6 +5492,11 @@ libxml2.")
(substitute* '("daemon/gdm-x-session.c")
(("X_SERVER")
"g_getenv (\"GDM_X_SERVER\")"))
+ ;; Use an absolute path for GNOME Session.
+ (substitute* "daemon/gdm-launch-environment.c"
+ (("\"gnome-session\"")
+ (string-append "\"" (assoc-ref inputs "gnome-session")
+ "/bin/gnome-session\"")))
#t))
;; GDM needs GNOME Session to run these applications. We link
;; their autostart files in `share/gdm/greeter/autostart'
@@ -5523,6 +5528,7 @@ libxml2.")
`(("accountsservice" ,accountsservice)
("check" ,check) ; for testing
("elogind" ,elogind)
+ ("gnome-session" ,gnome-session)
("gnome-settings-daemon" ,gnome-settings-daemon)
("gtk+" ,gtk+)
("iso-codes" ,iso-codes)