summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMohammed Sadiq <sadiq@sadiqpk.org>2017-09-22 21:38:44 +0530
committerLudovic Courtès <ludo@gnu.org>2017-09-23 18:35:24 +0200
commit60e2a9ae0f4cc28b9c69cb53bc7ff8f051210e70 (patch)
treecc4f77a79d820d0519452b74174e97e7583fece8 /gnu/packages/gnome.scm
parent0ec171ecb4d3ee253210dca1dc778383cd0fc400 (diff)
downloadpatches-60e2a9ae0f4cc28b9c69cb53bc7ff8f051210e70.tar
patches-60e2a9ae0f4cc28b9c69cb53bc7ff8f051210e70.tar.gz
gnu: Add gnome-clocks.
* gnu/packages/gnome.scm (gnome-clocks): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c0b5a8a41a..8380771243 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -52,6 +52,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -6023,6 +6024,44 @@ library.")
Microsoft SkyDrive and Hotmail, using their REST protocols.")
(license license:lgpl2.1+)))
+(define-public gnome-clocks
+ (package
+ (name "gnome-clocks")
+ (version "3.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00a5bqi1hbyb9kbl4p393l1g6rddl2y6ljxjby9c5j3k1qka0c0g"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t))
+ (native-inputs
+ `(("vala" ,vala)
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; for glib-compile-resources
+ ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gsound" ,gsound)
+ ("geoclue" ,geoclue)
+ ("geocode-glib" ,geocode-glib)
+ ("libgweather" ,libgweather)
+ ("gnome-desktop" ,gnome-desktop)))
+ (home-page "https://wiki.gnome.org/Apps/Clocks")
+ (synopsis "GNOME's clock application")
+ (description
+ "GNOME Clocks is a simple clocks application designed to fit the GNOME
+desktop. It supports world clock, stop watch, alarms, and count down timer.")
+ (license license:gpl3+)))
+
(define-public gnome-calendar
(package
(name "gnome-calendar")