summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-02-13 14:22:15 -0500
committerLudovic Courtès <ludo@gnu.org>2019-02-17 00:04:56 +0100
commit1d7bff4b4bdd60dfb3fb8150418e1a82c0ff2679 (patch)
treea66d4956c1ba0ad76f07e4da9713491a3a3654b0 /gnu/packages/gnome.scm
parente57c2adb2a7ed94610f4c35e8710bc1346199de6 (diff)
downloadpatches-1d7bff4b4bdd60dfb3fb8150418e1a82c0ff2679.tar
patches-1d7bff4b4bdd60dfb3fb8150418e1a82c0ff2679.tar.gz
gnu: gnome-session: Use absolute paths in .desktop files.
This makes the gnome-session .desktop files usable even if gnome-session is not available from the PATH variable. * gnu/packages/gnome.scm (gnome-session)[arguments]: Add a phase that adds the absolute path of gnome-session in its .desktop files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 21c61473c5..fb6645715e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4657,6 +4657,14 @@ such as gzip tarballs.")
(out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/gnome-session")
`("PATH" ":" prefix (,(string-append glib "/bin"))))
+ #t)))
+ (add-after 'install 'add-absolute-paths-to-desktop-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (substitute* (map (lambda (x)
+ (string-append out "/share/xsessions/" x))
+ '("gnome.desktop" "gnome-xorg.desktop"))
+ (("gnome-session") (string-append out "/bin/gnome-session")))
#t))))
#:configure-flags