summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-01-30 17:24:33 +0100
committerDavid Craven <david@craven.ch>2017-02-10 13:39:01 +0100
commit6c4f7022c6a731b4efb4a0bf3e6811759a540d65 (patch)
tree047149e387fa75e0e4fa8dbdee1266b6d6ac4cb2 /gnu/packages/gnome.scm
parent7b83b695d303c2b90f746758eb0429369bf993ed (diff)
downloadpatches-6c4f7022c6a731b4efb4a0bf3e6811759a540d65.tar
patches-6c4f7022c6a731b4efb4a0bf3e6811759a540d65.tar.gz
gnu: Add gnome-disk-utility.
* gnu/packages/gnome.scm (gnome-disk-utility): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c1ebc19c2a..8c099ee0df 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -324,6 +324,43 @@ Gnome project. It includes xml2po tool which makes it easier to translate
and keep up to date translations of documentation.")
(license license:gpl2+))) ; xslt under lgpl
+(define-public gnome-disk-utility
+ (package
+ (name "gnome-disk-utility")
+ (version "3.22.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hqynlcgwm72il2rdml98gcarz0alsgxs5xf6ww2x0czaj3s3953"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("docbook-xml" ,docbook-xml)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)))
+ (inputs
+ `(("glib" ,glib)
+ ("appstream-glib" ,appstream-glib)
+ ("gnome-settings-daemon" ,gnome-settings-daemon)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libdvdread" ,libdvdread)
+ ("libnotify" ,libnotify)
+ ("libpwquality" ,libpwquality)
+ ("libsecret" ,libsecret)
+ ("udisks" ,udisks)))
+ (home-page "https://git.gnome.org/browse/gnome-disk-utility")
+ (synopsis "Disk management utility for GNOME")
+ (description "Disk management utility for GNOME.")
+ (license license:gpl2+)))
+
(define-public gcr
(package
(name "gcr")