summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-02-13 14:22:19 -0500
committerLudovic Courtès <ludo@gnu.org>2019-02-17 00:04:57 +0100
commit1f564c1573f2d120a55e3b321a0c558a51720bce (patch)
tree256f30dde170a685ed67258d8d0227bcbf5b5b1f /gnu/packages/gnome.scm
parentc9ff92b550f4cb27f07ff093d59fc201ffea7e80 (diff)
downloadpatches-1f564c1573f2d120a55e3b321a0c558a51720bce.tar
patches-1f564c1573f2d120a55e3b321a0c558a51720bce.tar.gz
gnu: gdm: Run dbus-daemon via a wrapper script.
* gnu/packages/gnome.scm (gdm)[arguments]: Modify the pre-configure phase so that GDM propagates the GDM_DBUS_DAEMON variable into the session environment and uses its value to invoke dbus-daemon. * gnu/services/xorg.scm (dbus-daemon-wrapper): New variable. (<gdm-configuration>): Add 'dbus-daemon' field. (gdm-shepherd-service): Set GDM_DBUS_DAEMON before invoking gdm. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dec567a0e0..794f3a8843 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5461,6 +5461,7 @@ libxml2.")
(("DATADIR \"/gnome")
"\"/run/current-system/profile/share/gnome"))
(let ((propagate '("GDM_CUSTOM_CONF"
+ "GDM_DBUS_DAEMON"
"GDM_X_SERVER"
;; XXX: Remove this once GNOME Shell is
;; a dependency of GDM.
@@ -5486,6 +5487,8 @@ libxml2.")
(("\\(X_SERVER X_SERVER_ARG_FORMAT")
"(\"%s\" X_SERVER_ARG_FORMAT, g_getenv (\"GDM_X_SERVER\")"))
(substitute* '("daemon/gdm-x-session.c")
+ (("\"dbus-daemon\"")
+ "g_getenv (\"GDM_DBUS_DAEMON\")")
(("X_SERVER")
"g_getenv (\"GDM_X_SERVER\")"))
;; Use an absolute path for GNOME Session.