summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-07 21:35:35 -0500
committerLudovic Courtès <ludo@gnu.org>2018-01-08 15:11:18 +0100
commit64a153bd1a81bd50f259553188edb2464221bb34 (patch)
treecf8b6f7a9bdc4d5a4914a7625f533c7700e9741a /gnu/packages/gnome.scm
parenta4258dfa62bf4f59ce450a17f3663f85be5c0ce9 (diff)
downloadpatches-64a153bd1a81bd50f259553188edb2464221bb34.tar
patches-64a153bd1a81bd50f259553188edb2464221bb34.tar.gz
gnu: librsvg: Disable more failing tests.
* gnu/packages/gnome.scm (librsvg)[arguments]: Rename 'remove-failing-test' phase to 'remove-failing-tests'. Disable more tests that fail on i686 and armhf. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 835d1c0bf1..70926263c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
@@ -1207,11 +1207,19 @@ dealing with different structured file formats.")
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
#t))
- (add-after 'unpack 'remove-failing-test
- ;; This test fails on aarch64.
+ (add-after 'unpack 'remove-failing-tests
(lambda _
- (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children.svg")
- (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children-ref.png")
+ (with-directory-excursion "tests/fixtures/reftests"
+ (for-each delete-file
+ '(;; This test fails on i686:
+ "svg1.1/masking-path-04-b.svg"
+ "svg1.1/masking-path-04-b-ref.png"
+ ;; This test fails on armhf:
+ "svg1.1/masking-mask-01-b.svg"
+ "svg1.1/masking-mask-01-b-ref.png"
+ ;; This test fails on aarch64:
+ "bugs/777834-empty-text-children.svg"
+ "bugs/777834-empty-text-children-ref.png")))
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)