summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-07 15:41:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-07 15:46:53 +0200
commit341225ac6ccf1e2fcf52a58fb4230586a53bae05 (patch)
tree2ebace1a37f700f54ba0a39295b3f36fbfac6d98 /gnu/packages/gnome.scm
parent1df38cfcc78b750567f292a173e43a2633757cb0 (diff)
downloadpatches-341225ac6ccf1e2fcf52a58fb4230586a53bae05.tar
patches-341225ac6ccf1e2fcf52a58fb4230586a53bae05.tar.gz
gnu: gnome-control-center: Patch file name of 'nm-connection-editor'.
* gnu/packages/gnome.scm (gnome-control-center)[argument]: In 'patch-paths' phase, provide absolute file name to 'nm-connection-editor' in panels/network/*.c
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3e51e9cf9b..7c40a39f01 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5838,7 +5838,8 @@ devices using the GNOME desktop.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((libc (assoc-ref inputs "libc"))
(tzdata (assoc-ref inputs "tzdata"))
- (libgnomekbd (assoc-ref inputs "libgnomekbd")))
+ (libgnomekbd (assoc-ref inputs "libgnomekbd"))
+ (nm-applet (assoc-ref inputs "network-manager-applet")))
(substitute* "panels/datetime/tz.h"
(("/usr/share/zoneinfo/zone.tab")
(string-append tzdata "/share/zoneinfo/zone.tab")))
@@ -5849,6 +5850,12 @@ devices using the GNOME desktop.")
(("\"gkbd-keyboard-display")
(string-append "\"" libgnomekbd
"/bin/gkbd-keyboard-display")))
+ (substitute* '("panels/network/net-device-wifi.c"
+ "panels/network/net-device.c"
+ "panels/network/connection-editor/net-connection-editor.c")
+ (("\"nm-connection-editor")
+ (string-append "\"" nm-applet
+ "/bin/nm-connection-editor")))
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.