summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-06-19 21:17:49 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-06-19 21:35:50 +0200
commit737d1b3cd6fd583903428545cdd6bac0f5f6faab (patch)
tree5c9eb9f86239a9f2fa3766eb2df61bb720f08646 /gnu/packages/gnome.scm
parent2b94c14c9e7bbd2f582e6b5df89424dd089fc78f (diff)
downloadpatches-737d1b3cd6fd583903428545cdd6bac0f5f6faab.tar
patches-737d1b3cd6fd583903428545cdd6bac0f5f6faab.tar.gz
gnu: faba-icon-theme: Fix build.
* gnu/packages/gnome.scm (faba-icon-theme)[arguments]: Do not run configure during the bootstrap phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1d53af7515..f66ac7446d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6486,6 +6486,12 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(substitute* '("Makefile.am")
(("\\$\\(DESTDIR\\)/usr/share")
"$(datadir)"))
+ #t))
+ (add-after 'unpack 'disable-configure-during-bootstrap
+ (lambda _
+ ;; Do not run configure as part of autogen.sh because references
+ ;; to /bin are not fixed yet.
+ (setenv "NOCONFIGURE" "y")
#t)))))
(native-inputs
`(("autoconf" ,autoconf)