summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2019-10-21 19:16:24 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-22 18:32:52 +0200
commitaf561664b8191e2a34570176422f4d500d5fd4fb (patch)
tree83c98533a3e1eaa170b2face8cd7ea58b088e327 /gnu/packages/gnome.scm
parent84af1e74029fd4c43636f7d8d3e6f82ddab9ce82 (diff)
downloadpatches-af561664b8191e2a34570176422f4d500d5fd4fb.tar
patches-af561664b8191e2a34570176422f4d500d5fd4fb.tar.gz
gnu: seahorse: Update to 3.30.1.1.
* gnu/packages/gnome.scm (seahorse)[version]: Update version number. [origin]: Update hash. Add patch needed for compilation with our version of libsecret (0.19.1). [inputs]: Add avahi dependency. [native-inputs]: Add vala dependency. Use gettext-minimal instead of intltool, as only xgettext is used. * gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3a4494b2b5..6ce3b1cf37 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2223,7 +2223,7 @@ engineering.")
(define-public seahorse
(package
(name "seahorse")
- (version "3.30")
+ (version "3.30.1.1")
(source
(origin
(method url-fetch)
@@ -2232,8 +2232,19 @@ engineering.")
version ".tar.xz"))
(sha256
(base32
- "1sbj1czlx1fakm72dwgbn0bwm12j838yaky4mkf6hf8j8afnxmzp"))))
- (build-system glib-or-gtk-build-system)
+ "12x7xmwh62yl0ax90v8nkx3jqzviaz9hz2g56yml78wzww20gawy"))
+ (patches (search-patches
+ "seahorse-gkr-use-0-on-empty-flags.patch"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(inputs
`(("gtk+" ,gtk+)
("gcr" ,gcr)
@@ -2241,13 +2252,15 @@ engineering.")
("gpgme" ,gpgme)
("openldap" ,openldap)
("openssh" ,openssh)
+ ("avahi" ,avahi)
("libsecret" ,libsecret)
("libsoup" ,libsoup)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("itstool" ,itstool)
("pkg-config" ,pkg-config)
+ ("vala" ,vala)
("xmllint" ,libxml2)))
(home-page "https://launchpad.net/gnome-themes-standard")
(synopsis "Manage encryption keys and passwords in the GNOME keyring")