summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-07-19 12:05:58 -0400
committerTimothy Sample <samplet@ngyro.com>2019-07-19 12:56:09 -0400
commit1c9b99234c8322467ca22be70a94aa1678658476 (patch)
tree8db7d5b3292a0e3bcaf220a330a07ce7130e51de /gnu/packages/gnome.scm
parente1f174ae284d9954840f1723ac012c0d3fbcecb4 (diff)
downloadpatches-1c9b99234c8322467ca22be70a94aa1678658476.tar
patches-1c9b99234c8322467ca22be70a94aa1678658476.tar.gz
gnu: gnome-session: Do not patch in absolute paths.
This is no longer needed as upstream is now using absolute paths. * gnu/packages/gnome.scm (gnome-session): Remove phase that patches absolute paths into the session desktop entry files.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9190301ee9..3ac5025fce 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4806,14 +4806,6 @@ such as gzip tarballs.")
(out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/gnome-session")
`("PATH" ":" prefix (,(string-append glib "/bin"))))
- #t)))
- (add-after 'install 'add-absolute-paths-to-desktop-files
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (substitute* (map (lambda (x)
- (string-append out "/share/xsessions/" x))
- '("gnome.desktop" "gnome-xorg.desktop"))
- (("gnome-session") (string-append out "/bin/gnome-session")))
#t))))
#:configure-flags