summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-11-03 19:58:51 +1100
committerLudovic Courtès <ludo@gnu.org>2017-11-07 00:12:11 +0100
commitd935e6a12c0d4d7e17701675b62a188ec053b7fa (patch)
treeb1317c67dea1adb7ca9fdc8a929c12685e2e0a30 /gnu/packages/gnome.scm
parent47bd32d98e840a2ef9eb4ac009174162d9f2b325 (diff)
downloadpatches-d935e6a12c0d4d7e17701675b62a188ec053b7fa.tar
patches-d935e6a12c0d4d7e17701675b62a188ec053b7fa.tar.gz
gnu: Add faba-icon-theme.
* gnu/packages/gnome.scm (faba-icon-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e160818e51..2ea3c3b00e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
+;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6301,6 +6302,43 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
;; No "or later" language found.
(license license:gpl3)))
+(define-public faba-icon-theme
+ (package
+ (name "faba-icon-theme")
+ (version "4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/moka-project/"
+ name "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hi2dl627ayfnihn3v6x9xzid668m4hp098hb7hrkxvahh4h9by7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile.am
+ (lambda _
+ (substitute* '("Makefile.am")
+ (("\\$\\(DESTDIR\\)/usr/share")
+ "$(datadir)"))
+ #t))
+ (add-after 'patch-makefile.am 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vif")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Faba icon theme")
+ (description
+ "Faba is a minimal icon set used as a basis for other themes such as
+Moka")
+ (home-page "https://snwh.org/moka")
+ (license (list license:lgpl3+
+ license:cc-by-sa4.0))))
+
(define-public moka-icon-theme
(package
(name "moka-icon-theme")