summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-11-03 19:58:52 +1100
committerLudovic Courtès <ludo@gnu.org>2017-11-07 00:12:11 +0100
commit8b0e4177ee892c4c494338374c11d1b2475bd228 (patch)
tree4df063ddb3c695bdf0741c7469d56a5dc2b0d8c6 /gnu/packages/gnome.scm
parentd935e6a12c0d4d7e17701675b62a188ec053b7fa (diff)
downloadpatches-8b0e4177ee892c4c494338374c11d1b2475bd228.tar
patches-8b0e4177ee892c4c494338374c11d1b2475bd228.tar.gz
gnu: moka-icon-theme: Simplify package definition.
* gnu/packages/gnome.scm (moka-icon-theme): Inherit faba-icon-theme to avoid duplicating similar package definition. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2ea3c3b00e..205e3d177f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6341,6 +6341,7 @@ Moka")
(define-public moka-icon-theme
(package
+ (inherit faba-icon-theme)
(name "moka-icon-theme")
(version "5.3.6")
(source (origin
@@ -6352,26 +6353,9 @@ Moka")
(sha256
(base32
"04axinv79qnngsxkwqzi5j9lc3hn24rjqps5ai8d42pdnfaf0x37"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-makefile.am
- (lambda _
- (substitute* '("Makefile.am")
- (("\\$\\(DESTDIR\\)/usr/share")
- "$(datadir)"))
- #t))
- (add-after 'patch-makefile.am 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
(synopsis "Moka icon theme")
(description "Moka is a stylized desktop icon set, designed to be clear,
simple and consistent.")
- (home-page "http://snwh.org/moka")
(license license:gpl3+)))
(define-public arc-icon-theme