summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-27 10:17:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-27 10:17:14 +0100
commita557810ac72effd6841b76772195b10c03dee345 (patch)
tree26a4d7c1684d4c6fea155bfe05aa3b305499e36f /gnu/packages/gnome.scm
parent4c1918db34e09f0da793c607acc161bdf9ec5535 (diff)
parent2a19c0deb1da3a9afa8960367a5b84321386ceae (diff)
downloadpatches-a557810ac72effd6841b76772195b10c03dee345.tar
patches-a557810ac72effd6841b76772195b10c03dee345.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm87
1 files changed, 38 insertions, 49 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 870c4be4ab..12993eadef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3023,15 +3023,14 @@ keyboard shortcuts.")
(define-public colord
(package
(name "colord")
- (version "1.4.3")
+ (version "1.4.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/colord/releases/"
- name "-" version ".tar.xz"))
+ "colord-" version ".tar.xz"))
(sha256
- (base32
- "1xwxahg9mgmapc16xkb4kgmc40zpadrwav33xqmn6cgaw6g6d3ls"))))
+ (base32 "19f0938fr7nvvm3jr263dlknaq7md40zrac2npfyz25zc00yh3ws"))))
(build-system meson-build-system)
(arguments
'(;; FIXME: One test fails:
@@ -3046,13 +3045,12 @@ keyboard shortcuts.")
;; Wants to install to global completion dir;
;; punt.
"-Dbash_completion=false"
- ;; colord-gtk not packaged yet.
- "-Dsession_example=false"
"-Ddaemon_user=colord"
"-Dsane=true"
- ;; Requires spotread
+ "-Dvapi=true"
+ ;; Requires spotread.
"-Dargyllcms_sensor=false"
- ;; TODO: Requires docbook2x
+ ;; TODO: Requires docbook2x.
"-Dman=false")
#:phases
(modify-phases %standard-phases
@@ -3063,25 +3061,26 @@ keyboard shortcuts.")
(string-append "'" (assoc-ref outputs "out") "/lib/udev'")))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.
("gobject-introspection" ,gobject-introspection)
("gtk-doc" ,gtk-doc)
+ ("intltool" ,intltool)
("libtool" ,libtool)
- ("intltool" ,intltool)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
(propagated-inputs
;; colord.pc refers to all these.
`(("glib" ,glib)
- ("udev" ,eudev)
- ("lcms" ,lcms)))
+ ("lcms" ,lcms)
+ ("udev" ,eudev)))
(inputs
`(("dbus-glib" ,dbus-glib)
("gusb" ,gusb)
("libgudev" ,libgudev)
("libusb" ,libusb)
- ("sqlite" ,sqlite)
("polkit" ,polkit)
("python" ,python-wrapper)
+ ("sqlite" ,sqlite)
("sane-backends" ,sane-backends)))
(home-page "https://www.freedesktop.org/software/colord/")
(synopsis "Color management service")
@@ -4325,54 +4324,41 @@ USB transfers with your high-level application or system daemon.")
(define-public simple-scan
(package
(name "simple-scan")
- (version "3.24.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://launchpad.net/simple-scan/"
- (version-major+minor version) "/"
- version "/+download/simple-scan-"
- version ".tar.xz"))
- (sha256
- (base32
- "1czg21cdbd2fgqylxfnzfhhzy69gycf816d5bbaq6hb62hmq7bjy"))))
- (build-system glib-or-gtk-build-system)
+ (version "3.34.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/simple-scan/"
+ (version-major+minor version) "/"
+ "simple-scan-" version ".tar.xz"))
+ (sha256
+ (base32 "0glzskxdc7p9z7nwcakqc7qzij4l79adlvvb2cj5fmis731zw9yq"))))
+ (build-system meson-build-system)
+ ;; TODO: Fix icons in home screen, About dialogue, and scan menu.
+ (arguments
+ '(#:glib-or-gtk? #t))
(inputs
`(("gtk" ,gtk+)
("zlib" ,zlib)
("cairo" ,cairo)
+ ("colord" ,colord)
("gdk-pixbuf" ,gdk-pixbuf)
("gusb" ,gusb)
("libsane" ,sane-backends)))
(native-inputs
`(("gettext" ,gettext-minimal)
("itstool" ,itstool)
- ("colord" ,colord)
- ("glib" ,glib "bin") ; glib-compile-schemas, etc.
+ ("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)
("vala" ,vala)
("xmllint" ,libxml2)))
- (arguments
- '(#:configure-flags '("--disable-packagekit")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'clean
- (lambda _
- ;; Remove a left-over reference to PackageKit.
-
- ;; https://bugs.launchpad.net/simple-scan/+bug/1462769
-
- ;; There are some generated C files erroneously
- ;; included in the source distribution, and this
- ;; one breaks the build by referring to a
- ;; non-existent header (packagekit.h)
- (delete-file "src/ui.c"))))))
(home-page "https://gitlab.gnome.org/GNOME/simple-scan")
(synopsis "Document and image scanner")
- (description "Simple Scan is an easy-to-use application, designed to let
-users connect their scanner and quickly have the image/document in an
-appropriate format. Simple Scan is basically a frontend for SANE - which is
-the same backend as XSANE uses. This means that all existing scanners will
-work and the interface is well tested.")
+ (description
+ "Document Scanner is an easy-to-use application that lets you connect your
+scanner and quickly capture images and documents in an appropriate format. It
+supports any scanner for which a suitable SANE driver is available, which is
+almost all of them.")
(license license:gpl3+)))
(define-public eolie
@@ -7823,8 +7809,10 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(wrap-program (string-append out "/bin/lollypop")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
#t))
- (add-after 'install 'wrap
- (@@ (guix build python-build-system) wrap)))))
+ (add-after 'install 'wrap-python
+ (@@ (guix build python-build-system) wrap))
+ (add-after 'install 'wrap-glib-or-gtk
+ (@@ (guix build glib-or-gtk-build-system) wrap-all-programs)))))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
@@ -7833,6 +7821,7 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
("pkg-config" ,pkg-config)))
(inputs
`(("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gst-plugins-base" ,gst-plugins-base)
("libnotify" ,libnotify)
("libsecret" ,libsecret)