summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-14 17:18:28 -0500
committerLudovic Courtès <ludo@gnu.org>2020-01-15 23:48:32 +0100
commit04b201bb0feacd2997a66b73a574160f0b32697b (patch)
tree2f9c8005ced7b7004ad791212ddf21dab713135b /gnu/packages/gnome.scm
parent89af09020ad6e1fde509601cd242713fe3ba7178 (diff)
downloadpatches-04b201bb0feacd2997a66b73a574160f0b32697b.tar
patches-04b201bb0feacd2997a66b73a574160f0b32697b.tar.gz
gnu: Add sushi.
* gnu/packages/gnome.scm (sushi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b0f34fef5b..a6a8307649 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -582,6 +582,60 @@ sharing to the masses.")
(home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
(license license:gpl2+)))
+(define-public sushi
+ (package
+ (name "sushi")
+ (version "3.32.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "02idvqjk76lii9xyg3b1yz4rw721709bdm5j8ikjym6amcghl0aj"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/sushi")))
+ ;; Put existing typelibs before sushi's deps, so as to correctly
+ ;; infer gdk-pixbuf
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" suffix (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gettext" ,gettext-minimal)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("evince" ,evince) ; For file previewing.
+ ("freetype" ,freetype)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gjs" ,gjs)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gstreamer" ,gstreamer)
+ ("gtksourceview" ,gtksourceview-3)
+ ("harfbuzz" ,harfbuzz)
+ ("libepoxy" ,libepoxy)
+ ("libmusicbrainz" ,libmusicbrainz)
+ ("libxml2" ,libxml2)
+ ("neon" ,neon)
+ ("webkitgtk" ,webkitgtk)))
+ (synopsis "File previewer for the GNOME desktop")
+ (description "Sushi is a DBus-activated service that allows applications to
+preview files on the GNOME desktop.")
+ (home-page "https://gitlab.gnome.org/GNOME/sushi")
+ (license license:gpl2+)))
+
(define-public rygel
(package
(name "rygel")