summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 22:46:53 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:13 -0500
commitd9795e939e1ffc356b6e93215fc55dfe2d624507 (patch)
tree647a6cf0a21eb0e1b3a81e0f2d5e9e4cc86bc644 /gnu/packages/gnome.scm
parentd3b406969a0916fed8f7dc7c094de9d523ac12c9 (diff)
downloadpatches-d9795e939e1ffc356b6e93215fc55dfe2d624507.tar
patches-d9795e939e1ffc356b6e93215fc55dfe2d624507.tar.gz
gnu: five-or-more: Update to 3.32.0.
* gnu/packages/gnome.scm (five-or-more): Update to 3.32.0. [build-system]: Use meson-build-system. [arguments]: Set glib-or-gtk? flag and add 'skip-gtk-update-icon-cache' phase. [native-inputs]: Add appstream-glib, glib:bin and vala. [inputs]: Add libgnome-games-support.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7969d55788..c1efd9a57c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3103,7 +3103,7 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
(define-public five-or-more
(package
(name "five-or-more")
- (version "3.30.0")
+ (version "3.32.0")
(source
(origin
(method url-fetch)
@@ -3112,16 +3112,29 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
name "-" version ".tar.xz"))
(sha256
(base32
- "00d729p251kh96624i7qg2370r5mxwafs016i6hy01vsr71jzb9x"))))
- (build-system glib-or-gtk-build-system)
+ "0v52i22ygv6y4zqs8nyb1qmacmj9whhqrw7qss6vn7by4nsikhrn"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("appstream-glib" ,appstream-glib)
("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
("intltool" ,intltool)
("itstool" ,itstool)
+ ("vala" ,vala)
("xmllint" ,libxml2)))
(inputs
`(("gtk+" ,gtk+)
+ ("libgnome-games-support" ,libgnome-games-support)
("librsvg" ,librsvg)))
(home-page "https://wiki.gnome.org/Apps/Five%20or%20more")
(synopsis "Logic puzzle game")