summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2019-06-01 10:41:16 -0700
committerLudovic Courtès <ludo@gnu.org>2019-06-02 01:38:36 +0200
commit08be02bea1f51855318f7c11d920ed9eea13b65b (patch)
tree0230ccb1c4f60b74cbd76bf4709dd23309af0b1b /gnu/packages/gnome.scm
parent3eb261e2e54fe379071f47812bc52cc4b5b5e6c6 (diff)
downloadpatches-08be02bea1f51855318f7c11d920ed9eea13b65b.tar
patches-08be02bea1f51855318f7c11d920ed9eea13b65b.tar.gz
gnu: Add terminator.
* gnu/packages/gnome.scm (terminator): Add at 1.91 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 60141fce9b..561936f164 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -162,6 +162,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -8021,3 +8022,48 @@ functionality.")
(description "GThumb is an image viewer, browser, organizer, editor and
advanced image management tool")
(license license:gpl2+)))
+
+(define-public terminator
+ (package
+ (name "terminator")
+ (version "1.91")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/" name "/"
+ "gtk3/" version "/" "+download/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sdyqwydmdnh7j6mn74vrywz35m416kqsbxbrqcnv5ak08y6xxwm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("gobject-introspection" ,gobject-introspection)
+ ("python2-pycairo" ,python2-pycairo)
+ ("python2-pygobject" ,python2-pygobject)
+ ("python2-psutil" ,python2-psutil)
+ ("vte" ,vte)))
+ (arguments
+ `(#:python ,python-2 ;Python 3 not supported
+ #:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/terminator")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (home-page "https://gnometerminator.blogspot.com/")
+ (synopsis "Store and run multiple GNOME terminals in one window")
+ (description
+ "Terminator allows you to run multiple GNOME terminals in a grid and
++tabs, and it supports drag and drop re-ordering of terminals.")
+ (license license:gpl2)))