summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2019-12-29 11:45:24 -0500
committerJulien Lepiller <julien@lepiller.eu>2019-12-29 18:29:36 +0100
commit885424bf7f6e0bc0ad5dd9353690aa82d17dd8b8 (patch)
tree8c7f409ca6cbd7012f961eec37153a6cb3c59a23 /gnu/packages/gnome.scm
parenta4ee6ac444ca71a93101b48bc1e6a5710026266c (diff)
downloadpatches-885424bf7f6e0bc0ad5dd9353690aa82d17dd8b8.tar
patches-885424bf7f6e0bc0ad5dd9353690aa82d17dd8b8.tar.gz
gnu: gnome-themes-extra: Remove cache file.
* gnu/packages/gnome.scm (gnome-themes-extra)[arguments]: Disable cache file from configure flags. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4ad14caf7b..e0712bf99a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9091,6 +9091,12 @@ and a high score table.")
(base32
"06aqg9asq2vqi9wr29bs4v8z2bf4manhbhfghf4nvw01y2zs0jvw"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ ;; Don't create 'icon-theme.cache'.
+ (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
+ (true (string-append coreutils "/bin/true")))
+ (list (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
(native-inputs
`(("glib:bin" ,glib "bin")
("intltool" ,intltool)