summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-03 00:19:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-03 00:19:46 +0200
commit0d75c64d7844bf35b4e1cd09bcc50b2a1005c191 (patch)
treeb905a9ed7e1a37856d3f7630d2650f3f21cf5d32 /gnu/packages/gnome.scm
parent554e234ebb5e2adc1b21e518a07a66ce2c723782 (diff)
downloadpatches-0d75c64d7844bf35b4e1cd09bcc50b2a1005c191.tar
patches-0d75c64d7844bf35b4e1cd09bcc50b2a1005c191.tar.gz
gnu: glib-networking: Update to 2.60.3.
* gnu/packages/gnome.scm (glib-networking): Update to 2.60.3. [source](patches): Remove. [arguments]<#:phases>: Remove. * gnu/packages/patches/glib-networking-connection.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d3a348ba89..ecf39334e5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2595,7 +2595,7 @@ library.")
(define-public glib-networking
(package
(name "glib-networking")
- (version "2.58.0")
+ (version "2.60.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glib-networking/"
@@ -2603,18 +2603,10 @@ library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0s006gs9nsq6mg31spqha1jffzmp6qjh10y27h0fxf1iw1ah5ymx"))
- (patches (search-patches "glib-networking-connection.patch"))))
+ "1mfw44qpmwvz6yzj8c6spx6z357wrmkk15byrkc5byagd82860fm"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlibproxy_support=false")
- #:phases (modify-phases %standard-phases
- (add-before 'check 'disable-TLSv1.3
- (lambda _
- ;; XXX: One test fails when TLS 1.3 is enabled, fixed in 2.60.0:
- ;; <https://gitlab.com/gnutls/gnutls/issues/615>.
- (setenv "G_TLS_GNUTLS_PRIORITY" "NORMAL:-VERS-TLS1.3")
- #t)))))
+ `(#:configure-flags '("-Dlibproxy_support=false")))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))