summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-30 08:54:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:44:25 +0100
commit34c44a34abeea2b7ee5362f6c54a7348ef321065 (patch)
tree15692073cc6135ed4a98a5ce4507feb3b7577e6c /gnu/packages/gnome.scm
parenta6d378e2e7b37db686c73d7c374d7705beb4146c (diff)
downloadpatches-34c44a34abeea2b7ee5362f6c54a7348ef321065.tar
patches-34c44a34abeea2b7ee5362f6c54a7348ef321065.tar.gz
gnu: eog: Ensure RUNPATH contains output library directory.
* gnu/packages/gnome.scm (eog)[arguments]: Pass configure flag to add $out/lib/eog to RUNPATH.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2629b286f8..b019f46419 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3976,7 +3976,11 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
"1gasrfqi7qrzdq1idh29r0n6ikkqjb6pbp7a8k5krfz5hkhyfin0"))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ ;; Otherwise, the RUNPATH will lack the final 'eog' path component.
+ (list (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/eog"))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-eog
(lambda* (#:key outputs #:allow-other-keys)