summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-12-05 17:25:57 +0100
committerKei Kebreau <kkebreau@posteo.net>2019-06-20 23:24:37 -0400
commitb74ef0bae75525227de092c4844b920625095f65 (patch)
tree59e3f5c57f6e5a93bdebd78d239e16408f0d5ea6 /gnu/packages/gnome.scm
parent8c6d7b61bf05ee3c4154d8fc4279a20f509d2740 (diff)
downloadpatches-b74ef0bae75525227de092c4844b920625095f65.tar
patches-b74ef0bae75525227de092c4844b920625095f65.tar.gz
gnu: gdm: Update to 3.30.2.
* gnu/packages/gnome.scm (gdm): Update to 3.30.2. [arguments]: Add --with-udevdir configure flag. [source]: Remove patch. * gnu/packages/patches/gdm-CVE-2018-14424.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4a8c8049cf..787d9ab074 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5584,16 +5584,15 @@ libxml2.")
(define-public gdm
(package
(name "gdm")
- (version "3.28.2")
+ (version "3.30.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gdm-CVE-2018-14424.patch"))
(sha256
(base32
- "0wdm1503x66n1crdlmzmincbd2hccpxsdgjsl5anx3yjpdzs0hb0"))))
+ "1handy65r1n0zby09jr492b3643wszzigdkxp7q2ypgxb3hyv45y"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:configure-flags
@@ -5609,6 +5608,9 @@ libxml2.")
;; systemd-specific '/etc/locale.conf'.
"--with-lang-file=/etc/environment"
+ ,(string-append "--with-udevdir="
+ (assoc-ref %outputs "out") "/lib/udev")
+
"--localstatedir=/var"
,(string-append "--with-default-path="
(string-join '("/run/setuid-programs"