summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-17 10:23:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-17 10:23:02 +0200
commit5a0beca3aac7d22325229c8c044d23f9b038c20b (patch)
tree9df041d478a35ef2119ffe0baa2af4e244554cd5 /gnu/packages/gnome.scm
parent914c8cdf07944123312cef30020b991d0726c432 (diff)
downloadpatches-5a0beca3aac7d22325229c8c044d23f9b038c20b.tar
patches-5a0beca3aac7d22325229c8c044d23f9b038c20b.tar.gz
gnu: shotwell: Clean-up inputs.
* gnu/packages/gnome.scm (shotwell)[arguments]: Add phase to skip gtk-update-icon-cache. [inputs]: Sort alphabetically. Move glib:bin ... [native-inputs]: ... to here. Remove desktop-file-utils, gtk+:bin.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 82c86b65cc..0a9087eaff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5093,32 +5093,38 @@ metadata in photo and video files of various formats.")
"1m9i8r4gyd2hzlxjjwfyck4kz7gdg2vz2k6l6d0ga9hdfq2l4p9l"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t))
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") (which "true"))
+ (("update-desktop-database") (which "true")))
+ #t)))))
(propagated-inputs
`(("dconf" ,dconf)))
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
- ("gettext" ,gettext-minimal)
- ("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
("itstool" ,itstool)
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib:bin" ,glib "bin")
- ("gstreamer" ,gstreamer)
+ `(("gcr" ,gcr)
+ ("gexiv2" ,gexiv2)
("gst-plugins-base" ,gst-plugins-base)
+ ("gstreamer" ,gstreamer)
+ ("json-glib" ,json-glib)
("libgdata" ,libgdata)
("libgee" ,libgee)
- ("gexiv2" ,gexiv2)
+ ("libgphoto2" ,libgphoto2)
+ ("libgudev" ,libgudev)
("libraw" ,libraw)
- ("json-glib" ,json-glib)
- ("webkitgtk" ,webkitgtk)
- ("sqlite" ,sqlite)
("libsoup" ,libsoup)
("libxml2" ,libxml2)
- ("libgudev" ,libgudev)
- ("libgphoto2" ,libgphoto2)
- ("gcr" ,gcr)))
+ ("sqlite" ,sqlite)
+ ("webkitgtk" ,webkitgtk)))
(home-page "https://wiki.gnome.org/Apps/Shotwell")
(synopsis "Photo manager for GNOME 3")
(description