summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2019-12-24 08:04:16 -0500
committerEfraim Flashner <efraim@flashner.co.il>2019-12-24 18:11:33 +0200
commit3d217317885235b6567b58eebee377e6d1620a6c (patch)
tree819f28c7efd84e055205b3ce3eb169da58e71fea /gnu/packages/gnome.scm
parentb22119760b7907455c00c46117d9adb5735721d4 (diff)
downloadpatches-3d217317885235b6567b58eebee377e6d1620a6c.tar
patches-3d217317885235b6567b58eebee377e6d1620a6c.tar.gz
gnu: Add gnome-font-viewer.
* gnu/packages/gnome.scm (gnome-font-viewer): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 95da97e95d..76b3f4aa77 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -711,6 +711,42 @@ and keep up to date translations of documentation.")
(description "Disk management utility for GNOME.")
(license license:gpl2+)))
+(define-public gnome-font-viewer
+ (package
+ (name "gnome-font-viewer")
+ (version "3.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-font-viewer/"
+ (version-major+minor version)
+ "/gnome-font-viewer-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wwnx2zrlbd2d6np7m9s78alx6j6ranrnh1g2z6zrv9qcj8rpzz5"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-post-install-script
+ (lambda _
+ (substitute* "meson-postinstall.sh"
+ (("update-desktop-database") (which "true")))
+ #t)))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gtk+" ,gtk+)))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-font-viewer")
+ (synopsis "GNOME Fonts")
+ (description "Application to show you the fonts installed on your computer
+for your use as thumbnails. Selecting any thumbnails shows the full view of how
+the font would look under various sizes.")
+ (license license:gpl2+)))
+
(define-public gcr
(package
(name "gcr")