summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 22:56:26 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:13 -0500
commit2d817e415b7fb06dbde329dc98efde0720a6d4c0 (patch)
tree7fab8f24b41181b5bdf88271be1154dff05f405b /gnu/packages/gnome.scm
parentd9795e939e1ffc356b6e93215fc55dfe2d624507 (diff)
downloadpatches-2d817e415b7fb06dbde329dc98efde0720a6d4c0.tar
patches-2d817e415b7fb06dbde329dc98efde0720a6d4c0.tar.gz
gnu: gnome-mines: Update to 3.32.2.
* gnu/packages/gnome.scm (gnome-mines): Update to 3.32.2. [arguments]: Set glib-or-gtk? flag. Add 'skip-gtk-update-icon-cache' phase; remove deletion of 'bootstrap' phase which has been obsolete since commit 25280065814aecd7ce56baf4866b0c05acf8028b.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c1efd9a57c..4785437323 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3147,7 +3147,7 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
(define-public gnome-mines
(package
(name "gnome-mines")
- (version "3.30.1.1")
+ (version "3.32.2")
(source
(origin
(method url-fetch)
@@ -3156,12 +3156,17 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
name "-" version ".tar.xz"))
(sha256
(base32
- "08ddk400sg1g3q26gnm5mgv81vdqyix0yl7pd47p50vkc1w6f33z"))))
+ "1nv966wkp2rqxzcdb76bwlbzpjqadcaqzrnkxpzwnvjjr167yx8g"))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ '(#:glib-or-gtk? #t
+ #:phases
(modify-phases %standard-phases
- (delete 'bootstrap))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))
+ #t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources
("pkg-config" ,pkg-config)