summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-12-22 16:03:43 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-12-23 09:36:53 +0200
commitd17eb1011c1b69335a82a47f1d23878647ecf77f (patch)
tree8e30e40608f81c0ef5e2c6b6d0a7b61fcc52aef9 /gnu/packages/gnome-xyz.scm
parent5a947e118fb72b8fb1fd0c8d0b783fc7cde0c461 (diff)
downloadpatches-d17eb1011c1b69335a82a47f1d23878647ecf77f.tar
patches-d17eb1011c1b69335a82a47f1d23878647ecf77f.tar.gz
gnu: gnome-shell-extension-hide-app-icon: Fix installation.
* gnu/packages/gnome-xyz.scm: (gnome-shell-extension-hide-app-icon): [arguments]: Install in subdirectory. Adjust indentation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4b5e07a1a0..64fac5e3e6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -158,15 +158,16 @@ faster window switching.")
(name "gnome-shell-extension-hide-app-icon")
(version (git-version "2.7" revision commit))
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
- (commit commit)))
- (sha256
- (base32
- "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
- (file-name (git-file-name name version))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/michael-rapp"
+ "/gnome-shell-extension-hide-app-icon.git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test target
@@ -178,10 +179,11 @@ faster window switching.")
(delete 'configure) ; no configure script
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (copy-recursively "hide-app-icon@mrapp.sourceforge.com/"
- (string-append out "/share/gnome-shell/extensions"))
- #t))))))
+ (let ((out (assoc-ref outputs "out"))
+ (pre "/share/gnome-shell/extensions/")
+ (dir "hide-app-icon@mrapp.sourceforge.com"))
+ (copy-recursively dir (string-append out pre dir))
+ #t))))))
(native-inputs
`(("glib" ,glib "bin")
("intltool" ,intltool)))
@@ -190,10 +192,11 @@ faster window switching.")
(synopsis "Hide app icon from GNOME's panel")
(description "This extension allows to hide the icon and/or title of the
currently focused application in the top panel of the GNOME shell.")
- (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+ (home-page
+ "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
(license
- ;; README.md and LICENSE.txt disagree -- the former claims v3, the
- ;; latter v2. No mention of "or later" in either place or in the code.
+ ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+ ;; latter v2. No mention of "or later" in either place or in the code.
(list license:gpl2
license:gpl3)))))