summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-09 10:39:28 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-09 23:04:15 +0100
commitec574bb3fb5131fcb904248f307095d5ed29e6b7 (patch)
treefa8b8dac3bb41fa862601282e8af93a7ae440cdb /gnu/packages/gnome-xyz.scm
parent0758a70cc008171f31c848128deca9803536fe60 (diff)
downloadpatches-ec574bb3fb5131fcb904248f307095d5ed29e6b7.tar
patches-ec574bb3fb5131fcb904248f307095d5ed29e6b7.tar.gz
gnu: Add matcha-theme.
* gnu/packages/gnome-xyz.scm (matcha-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8c45b552e8..27171d31a2 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,9 +24,58 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages pkg-config))
+(define-public matcha-theme
+ (package
+ (name "matcha-theme")
+ (version "2019-11-02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/matcha")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (source (assoc-ref %build-inputs "source"))
+ (bash (assoc-ref %build-inputs "bash"))
+ (coreutils (assoc-ref %build-inputs "coreutils"))
+ (themesdir (string-append out "/share/themes")))
+ (setenv "PATH"
+ (string-append coreutils "/bin:"
+ (string-append bash "/bin:")))
+ (copy-recursively source (getcwd))
+ (patch-shebang "Install")
+ (mkdir-p themesdir)
+ (invoke "./Install" "-d" themesdir)
+ #t))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(("bash" ,bash)
+ ("coreutils" ,coreutils)))
+ (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
+ (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
+Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
+like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
+ (home-page "https://github.com/vinceliuice/matcha")
+ (license license:gpl3+)))
+
(define-public delft-icon-theme
(package
(name "delft-icon-theme")