summaryrefslogtreecommitdiff
path: root/gnu/packages/global.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-12 11:40:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-12 11:40:27 +0100
commit99e64a6e7742b8c3727968e5d094e71d33c5cb3f (patch)
tree8741828cb58778dfdba76377a7d1c4bf3fe63b40 /gnu/packages/global.scm
parent23153c907bb2de46e517343ab43c08e0cfe4ef90 (diff)
downloadpatches-99e64a6e7742b8c3727968e5d094e71d33c5cb3f.tar
patches-99e64a6e7742b8c3727968e5d094e71d33c5cb3f.tar.gz
gnu: Move cflow, Complexity, and GLOBAL to (gnu packages code).
* gnu/packages/code.scm (cflow, complexity, global): New variables. * gnu/packages/cflow.scm, gnu/packages/complexity.scm, gnu/packages/global.scm: Remove. * gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly.
Diffstat (limited to 'gnu/packages/global.scm')
-rw-r--r--gnu/packages/global.scm67
1 files changed, 0 insertions, 67 deletions
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
deleted file mode 100644
index 99d83f4f9b..0000000000
--- a/gnu/packages/global.scm
+++ /dev/null
@@ -1,67 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages global)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (guix licenses)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages))
-
-(define-public global ; a global variable
- (package
- (name "global")
- (version "6.3.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/global/global-"
- version ".tar.gz"))
- (sha256
- (base32
- "0hcplcayyjf42d8ygzla6142b5dq4ybq4wg3n3cgx3b5yfhvic85"))))
- (build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)
- ("libltdl" ,libltdl)))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-ncurses="
- (assoc-ref %build-inputs "ncurses")))
-
- #:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install the Emacs Lisp file in the right place.
- (let* ((out (assoc-ref outputs "out"))
- (data (string-append out "/share/gtags"))
- (lisp (string-append out "/share/emacs/site-lisp")))
- (mkdir-p lisp)
- (copy-file (string-append data "/gtags.el")
- (string-append lisp "/gtags.el"))
- (delete-file (string-append data "/gtags.el"))
- #t))
- %standard-phases)))
- (home-page "http://www.gnu.org/software/global/")
- (synopsis "Cross-environment source code tag system")
- (description
- "GLOBAL is a source code tagging system that functions in the same way
-across a wide array of environments, such as different text editors, shells
-and web browsers. The resulting tags are useful for quickly moving around in
-a large, deeply nested project.")
- (license gpl3+)))