summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 23:33:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:09 +0100
commit785fcb62fecde1c275fd5bd5da488ef345f456d9 (patch)
treeaa94a6b8d4e2a69d7e5c88de89775bd58975a021 /gnu/packages/glib.scm
parent9092e3e936c747932140e7a5389219ee8c4580f6 (diff)
downloadpatches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar
patches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar.gz
gnu: Remove python-libxml2 workaround.
* gnu/packages/xml.scm (python-libxml2)[source]: New field. (python-libxml2/fixed): Remove variable. * gnu/packages/glib.scm (itstool/fixed): Remove variable. * gnu/packages/gnome.scm (gnumeric)[native-inputs]: Replace ITSTOOL/FIXED with ITSTOOL. (yelp-tools/fixed): Remove variable. * gnu/packages/mate.scm (mate-applets, mate-utils)[native-inputs]: Replace YELP-TOOLS/FIXED with YELP-TOOLS.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm10
1 files changed, 0 insertions, 10 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index eb37b9e824..ff5206e7fd 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -540,16 +540,6 @@ information in their documents, such as whether a particular element should be
translated.")
(license license:gpl3+)))
-(define-public itstool/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. Since the issue is quite rare,
- ;; create this variant here to avoid a full rebuild.
- (package/inherit
- itstool
- (inputs
- `(("python-libxml2" ,python-libxml2/fixed)
- ,@(alist-delete "python-libxml2" (package-inputs itstool))))))
-
(define dbus-glib
(package
(name "dbus-glib")