summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-09 15:31:23 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-09 15:31:23 +0100
commitf5a9103991531d17bd1d5a944dcec1c49fb9f395 (patch)
tree3d8e311b01896ea9b709322fdf0e0dc3d7e09f44 /gnu/packages/glib.scm
parent255f730879ec6b3b655a54b44374a3b0a905145c (diff)
downloadpatches-f5a9103991531d17bd1d5a944dcec1c49fb9f395.tar
patches-f5a9103991531d17bd1d5a944dcec1c49fb9f395.tar.gz
gnu: dbus: Incorporate "dbus-helper-search-path.patch".
* gnu/packages/glib.scm (dbus)[source]: Apply "dbus-helper-search-path.patch". (dbus/activation): Remove. * gnu/services/dbus.scm (<dbus-configuration>)[dbus]: Default to DBUS. (dbus-service): Likewise.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bc69af5a9e..16a1a6162d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -61,14 +61,15 @@
(name "dbus")
(version "1.10.0")
(source (origin
- ;; TODO: Apply patch from DBUS/ACTIVATION below.
(method url-fetch)
(uri (string-append
"https://dbus.freedesktop.org/releases/dbus/dbus-"
version ".tar.gz"))
(sha256
(base32
- "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))))
+ "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
+ (patches
+ (list (search-patch "dbus-helper-search-path.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -126,17 +127,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
-(define-public dbus/activation
- ;; D-Bus with a patch to fix service activation.
- ;; TODO: Merge with DBUS above.
- (package
- (inherit dbus)
- (version (string-append (package-version dbus) ".a"))
- (source (origin
- (inherit (package-source dbus))
- (patches
- (list (search-patch "dbus-helper-search-path.patch")))))))
-
(define glib
(package
(name "glib")