summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 04:47:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 16:06:10 +0100
commite0f71c802c8e15257cd5d279c6419557806a5d0f (patch)
treee287c7f58006cb74f1711d9db6432527bca7472d /gnu/packages/glib.scm
parentedbce464b9c3e219fc8aeed76fb089f338fb13c1 (diff)
downloadpatches-e0f71c802c8e15257cd5d279c6419557806a5d0f.tar
patches-e0f71c802c8e15257cd5d279c6419557806a5d0f.tar.gz
gnu: intltool: Update phase style.
* gnu/packages/glib.scm (intltool)[arguments]: Use MODIFY-PHASES syntax and end phase with #t.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c0d4fe0e90..bc449e1f71 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -368,13 +368,14 @@ bindings to call into the C library.")
("perl-xml-parser" ,perl-xml-parser)
("perl" ,perl)))
(arguments
- `(#:phases (alist-cons-after
- 'unpack 'patch-file-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((file (assoc-ref inputs "file")))
- (substitute* "intltool-update.in"
- (("`file") (string-append "`" file "/bin/file")))))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file (assoc-ref inputs "file")))
+ (substitute* "intltool-update.in"
+ (("`file") (string-append "`" file "/bin/file")))
+ #t))))))
(home-page "https://launchpad.net/intltool/+download")
(synopsis "Tools to centralise translations of different file formats")
(description