summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-18 00:12:39 -0400
committerMark H Weaver <mhw@netris.org>2018-03-18 00:49:01 -0400
commit953468743fa1bbcc81989ce04de64cb1f1ab540f (patch)
treeac8c0a3f8978556f99c03540061c6fe99380966c /gnu/packages/glib.scm
parent196fb12cb8311ced90e51d9246deeea432ecce58 (diff)
downloadpatches-953468743fa1bbcc81989ce04de64cb1f1ab540f.tar
patches-953468743fa1bbcc81989ce04de64cb1f1ab540f.tar.gz
gnu: gobject-introspection: Disable parallel build.
* gnu/packages/glib.scm (gobject-introspection)[arguments]: New field.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 4a5dc12a49..ed2004fbbb 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -320,6 +320,10 @@ dynamic loading, and an object system.")
"gobject-introspection-girepository.patch"
"gobject-introspection-absolute-shlib-path.patch"))))
(build-system gnu-build-system)
+ (arguments
+ ;; The build system has at least one race condition involving Gio-2.0.gir
+ ;; which causes intermittent failures, as of 1.56.0.
+ `(#:parallel-build? #f))
(inputs
`(("bison" ,bison)
("flex" ,flex)