summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-14 23:38:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-15 00:02:46 +0100
commit2f437b22e2f78acd783db7f6b5f736a38ecf3e8e (patch)
tree936e9cdf6f553f0e723a945f6bceb450ccdaa2d0 /gnu/packages/glib.scm
parentf74181d40fe10605eb1a08801139d42536db5252 (diff)
downloadpatches-2f437b22e2f78acd783db7f6b5f736a38ecf3e8e.tar
patches-2f437b22e2f78acd783db7f6b5f736a38ecf3e8e.tar.gz
gnu: glib: Update to 2.56.0.
* gnu/packages/glib.scm (glib): Update to 2.56.0. [source](patches): Remove obsolete patch. [arguments]: Disable new MIME test. * gnu/packages/patches/glib-respect-datadir.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 34968f9d91..15885324c7 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -148,7 +148,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.54.3")
+ (version "2.56.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -156,9 +156,8 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1a60p9m493mvm42rskg8ifr0jmsbr8arzyqx73jshgfwhmkdqgwn"))
- (patches (search-patches "glib-respect-datadir.patch"
- "glib-tests-timer.patch"))))
+ "1iqgi90fmpl3l23jm2iv44qp7hqsxvnv7978s18933bvx4bnxvzc"))
+ (patches (search-patches "glib-tests-timer.patch"))))
(build-system gnu-build-system)
(outputs '("out" ; everything
"bin" ; glib-mkenums, gtester, etc.; depends on Python
@@ -235,6 +234,7 @@ shared NFS home directories.")
("gio/tests/contenttype.c"
(;; XXX: requires shared-mime-info.
"/contenttype/guess"
+ "/contenttype/guess_svg_from_data"
"/contenttype/subtype"
"/contenttype/list"
"/contenttype/icon"