summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-24 16:29:29 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-25 12:42:50 -0400
commitae40e02cd68d4e0ab10690bd4e59c698df472857 (patch)
tree528efcb81fb3499b449b34a9fd42e9917b2cbb27 /gnu/packages/glib.scm
parent7a0d78fc52440c72954ef8ac446e3a7989cf5e8c (diff)
downloadpatches-ae40e02cd68d4e0ab10690bd4e59c698df472857.tar
patches-ae40e02cd68d4e0ab10690bd4e59c698df472857.tar.gz
gnu: python-pyobject: Update to 3.24.1.
* gnu/packages/glib.scm (python-pyobject, python2-pyobject): Update to 3.24.1. [arguments]: Remove field. [native-inputs]: Add dbus.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a20685da03..fcd1daf5e8 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -573,7 +573,7 @@ useful for C++.")
(define-public python-pygobject
(package
(name "python-pygobject")
- (version "3.22.0")
+ (version "3.24.1")
(source
(origin
(method url-fetch)
@@ -582,11 +582,13 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
- "1ryblpc4wbhxcwf7grgib4drrab5xi6p78ihhrx0zj7g13xrrch8"))))
+ "1zdzznrj2s1gsrv2z4r0n88fzba8zjc1n2r313xi77lhl1daja56"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)
- ("glib-bin" ,glib "bin") ;for tests: glib-compile-schemas
+ ;for tests: dbus-run-session and glib-compile-schemas
+ ("dbus" ,dbus)
+ ("glib-bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(inputs
`(("python" ,python)
@@ -596,16 +598,6 @@ useful for C++.")
;; pygobject-3.0.pc refers to all these.
`(("glib" ,glib)
("libffi" ,libffi)))
- (arguments
- ;; TODO: failing tests: test_native_calls_async
- ;; test_native_calls_async_errors test_native_calls_sync
- ;; test_native_calls_sync_errors test_python_calls_async
- ;; test_python_calls_async_error test_python_calls_async_error_result
- ;; test_python_calls_sync test_python_calls_sync_errors
- ;; test_python_calls_sync_noargs test_callback_user_data_middle_none
- ;; test_callback_user_data_middle_single
- ;; test_callback_user_data_middle_tuple
- '(#:tests? #f))
;; For finding typelib files, since gobject-introscpetion isn't propagated.
(native-search-paths (package-native-search-paths gobject-introspection))
(home-page "https://live.gnome.org/PyGObject")