summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 00:09:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 00:11:34 +0200
commit01eafd38fbeb49d8167d99569eb624ab404bbeb2 (patch)
treecfbde1f3b011ee586bf4ce45b7f83d10fc28e2f4 /gnu/packages/glib.scm
parentac10e0e17e366d354ad8b3f91e03c1bdeddc7632 (diff)
downloadpatches-01eafd38fbeb49d8167d99569eb624ab404bbeb2.tar
patches-01eafd38fbeb49d8167d99569eb624ab404bbeb2.tar.gz
gnu: Use the 'patches' field of <origin>.
* gnu/packages/apr.scm, gnu/packages/autotools.scm, gnu/packages/avahi.scm, gnu/packages/cdrom.scm, gnu/packages/cmake.scm, gnu/packages/cpio.scm, gnu/packages/cross-base.scm, gnu/packages/emacs.scm, gnu/packages/flex.scm, gnu/packages/fontutils.scm, gnu/packages/glib.scm, gnu/packages/grub.scm, gnu/packages/guile.scm, gnu/packages/idutils.scm, gnu/packages/libevent.scm, gnu/packages/linux.scm, gnu/packages/mail.scm, gnu/packages/make-bootstrap.scm, gnu/packages/mp3.scm, gnu/packages/oggvorbis.scm, gnu/packages/pdf.scm, gnu/packages/plotutils.scm, gnu/packages/qemu.scm, gnu/packages/recutils.scm, gnu/packages/rush.scm, gnu/packages/scheme.scm, gnu/packages/system.scm, gnu/packages/tcsh.scm, gnu/packages/valgrind.scm, gnu/packages/vpn.scm, gnu/packages/w3m: Use the 'patches' field of <origin> instead of adding a patch as input plus using #:patches.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 0d0f186aee..2fbc46892b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -64,7 +64,8 @@
version ".tar.gz"))
(sha256
(base32
- "1wacqyfkcpayg7f8rvx9awqg275n5pksxq5q7y21lxjx85x6pfjz"))))
+ "1wacqyfkcpayg7f8rvx9awqg275n5pksxq5q7y21lxjx85x6pfjz"))
+ (patches (list (search-patch "dbus-localstatedir.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list ;; Install the system bus socket under /var.
@@ -74,13 +75,10 @@
;; config.
;; "--sysconfdir=/etc"
- "--with-session-socket-dir=/tmp")
- #:patches (list (assoc-ref %build-inputs "patch/localstatedir"))))
+ "--with-session-socket-dir=/tmp")))
(inputs
`(("expat" ,expat)
("pkg-config" ,pkg-config)
- ("patch/localstatedir"
- ,(search-patch "dbus-localstatedir.patch"))
;; Add a dependency on libx11 so that 'dbus-launch' has support for
;; '--autolaunch'.
@@ -116,7 +114,10 @@ shared NFS home directories.")
name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0cpzqadqk6z6bmb79p04pykxc8x57rvshh33414cnk41bvgaf4vm"))))
+ (base32 "0cpzqadqk6z6bmb79p04pykxc8x57rvshh33414cnk41bvgaf4vm"))
+ (patches (list (search-patch "glib-tests-homedir.patch")
+ (search-patch "glib-tests-desktop.patch")
+ (search-patch "glib-tests-prlimit.patch")))))
(build-system gnu-build-system)
(outputs '("out" ; everything
"doc")) ; 20 MiB of GTK-Doc reference
@@ -131,18 +132,9 @@ shared NFS home directories.")
("dbus" ,dbus) ; for GDBus tests
("bash" ,bash)
("tzdata" ,tzdata) ; for tests/gdatetime.c
-
- ("patch/tests-homedir"
- ,(search-patch "glib-tests-homedir.patch"))
- ("patch/tests-desktop"
- ,(search-patch "glib-tests-desktop.patch"))
- ("patch/tests-prlimit"
- ,(search-patch "glib-tests-prlimit.patch"))))
+ ))
(arguments
- '(#:patches (list (assoc-ref %build-inputs "patch/tests-homedir")
- (assoc-ref %build-inputs "patch/tests-desktop")
- (assoc-ref %build-inputs "patch/tests-prlimit"))
- #:phases (alist-cons-before
+ '(#:phases (alist-cons-before
'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.